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Pocket Recorder is a simple, easy to use Windows 3.1 based application for recording waveform data in 
an 8 or 16-bit format.    Pocket Recorder is the first in a family of multimedia Pocket Tools from Media 
Vision. You can use Pocket Recorder to record and playback waveform files (*.WAV) from any Windows 
application. You can also splice and blend files together for interesting audio effects. By default your view 
of the file being displayed is an outline of the entire file. The total length of your file is also conveniently 
displayed in seconds format in the status area.
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File Menu Commands
New

Creates a new file,

Open

Opens an existing waveform file for playback, recording and/or editing (including modifications performed 
using Pocket Recorders sound effects options). 

Save

Saves the current waveform file. If the current waveform is untitled you will be prompted to input a 
standard file name.

Save As...

Lets you save your file under a different name and extension. "Save As.." saves the current contents of 
the file being edited to a new file, without affecting either the contents or state of the current file. You can 
also choose to save the file in a compressed state, choosing 2 to 1 or 4 to 1 compression, thereby 
conserving disk space.

Revert

Causes the current waveform file to revert to the last saved version. This feature is helpful when you 
accidentally edit a wavefile. The revert selection actually recalls a temporary file in which all edits are 
stored. 

Set Temp Directory...

You can use the Set Temp Directory command to define where Pocket Recorder stores its temporary files.
This temporary directory is only used by Pocket Recorder and is not related to DOS' TEMP environment 
variable.    This command is useful is your DOS TEMP variable is set to a RAM drive of limited size (which
constrains the size of recordings and/or file editing operations). To use this command perform the 
following steps:

1. Select the Set Temp Drive option in the File menu.

2. If a file is loaded and has been modified, a message box appears asking whether the modification(s) 
should be saved or discarded.    Select either Yes or No. 

3. Next, a Set Temp Directory dialog box appears.    In this dialog box you can choose the current drive 
and directory for the applications temporary files.    

Selecting    the OK    button causes the application's temporary files to be recreated on the newly specified
drive and directory. 

Select the Remember check box to have Pocket Recorder permanently retain the    new path to the 
temporary drive and directory. It will remember this information the next time you open your Pocket 
Recorder application. 

Calculating TEMP File Size



The TEMP (temporary) file size is not dependent upon how much free space is available on your hard 
disk.    When the TEMP file reaches its maximum file size a message box appears. You must save the file 
at this point.    Any edits which increase the file size will not be saved. To calculate the amount of disk 
space which can be used to record a file, take the total free space of your temporary drive, subtract the 
size of the file (if any) currently loaded and divide by two.

Exit

The Exit command allows you to properly exit from the Pocket Recorder application. If there is an open 
waveform file currently being edited, you will be prompted to save changes.

About...

Displays information on which version of Pocket Recorder you are using and also displays the Media 
Vision logo.



Edit Menu Commands
In general, you can insert a file at any location within a waveform file, or if the current insertion point is at 
the end you can append to the end of    the file. However, you cannot mix two files which were recorded at
different sample rates. The two files to be joined must be of the same sample rate. Pocket Recorder does 
not currently support sample rate conversion.

Insert File 

Lets you place a file within your current file. The placement of the file is after the position of the current 
insertion point. If there is no current insertion point, the file is inserted at the beginning. This operation will 
increase the length of the file being edited by the amount of the file being inserted. 

Blend File 

This operation overlays one file on top of another (provided they are of the same sample rate and type).    
The length of the resulting file will be the same as the longest of the file used. This feature essentially 
merges two waveforms into one file.

NOTE: Saturation levels must be monitored while blending files.    Saturation is another form of distortion 
that occurs when the amplitude of a blended file is excessive. This is sometimes referred to as clipping.

Cut

Choose the Cut command to remove a selected part of a waveform.      When you choose Cut, Pocket 
Recorder removes the current selection from the file and places it in the clipboard (which replaces the 
clipboard's previous contents). 

Copy      

The Copy command copies the selected area of the waveform and places it in the clipboard ( although 
the selection still remains in the waveform view area).    

Paste 

The Paste command    inserts the contents of the clipboard into the waveform file.    You can choose Paste
several times to paste several copies of the same information.

Pocket Recorder's Paste command inserts the waveform data from the clipboard at the current position 
indicated in view area of the waveform file.    It is only possible to paste data which is of the exact format 
( e.g., sampling rates, bits per sample, and number of channels) as the waveform file which is currently 
displayed. For example, you cannot paste a 44 KHz, 16-bit , stereo region into a 22 KHz, 8-bit, mono 
waveform file.

Delete 

Deletes the waveform data contained in the highlighted region.    Unlike Copy and Cut, the Delete 
command does not place the selection in the clipboard.



Effects Menu Commands
Sound effects modify and/or change the waveform data.    If an unwanted or undesirable effect is 
performed use the    "Revert" command to    reload the last saved version of the waveform. 

It should be noted that all of the sound wave effects found on the "Effects" pull-down menu will irreversibly
modify the sound wave data.    Either of the file menu's "Save" or "Save As" commands may be used to 
save the original wave data before applying a wave effect.    Please see the File menu section for more 
information on saving and loading wave files.

Louder

Each successive selection of the Louder command increases the sound wave's loudness (or amplitude) 
by fifty percent (a multiplier of three halves).

Softer

Each successive selection of the Softer command decreases the sound wave's loudness    (or amplitude) 
by one third ( a multiplier of two thirds). Note that a "Louder" effect    leaves the waveform file at its original
loudness.    This is true, unless some of the values (or samples)    surpass their maximum value.    In this 
case it is possible to determine the original    values at those points.

Faster

Each successive selection of the Faster command doubles the speed (or rate) of the waveform file.

Slower

Each successive selection of the Slower command halves the speed    (or rate) of the waveform file.    In 
both the Faster and Slower commands, the waveform file's    pitch is held constant.    This is achieved    by 
either removing    (for Faster) or doubling (for Slower) small chunks of the wave    throughout the waveform
file. The size of these    wave chunks    is chosen to be much larger than a single sound oscillation so that 
the frequency (or pitch)    of the waveform file remains the same.    The value of the wave chunk size may 
be set by the use of the Voice command dialog box.    For more information on this topic, refer to the 
Voice... command section. 

Higher

Each successive selection of the Higher command increases the pitch (or frequency) of the sound wave 
by a factor of two.

Lower

Each successive selection of the Lower command decreases the pitch (or frequency) of the sound wave 
by a factor of one half. 

In both the Higher and Lower commands, the total duration of the sound wave is held constant.    The 
pitch alteration is achieved by either removing every other wave sample    to raise the pitch, or by doubling
each wave sample to lower the pitch.    In both cases, this process changes the sound wave's duration.    
The technique used in the Faster and Slower    commands is applied here to restore the sound wave to its
original duration, with its new modified pitch.

By using the Higher and Lower command, in conjunction with the Faster and Slower command, the pitch 
and duration may be changed together.    This is a more common feature found in other sound wave 
applications.    To get these effects with Pocket Recorder the best results are obtained by applying the 



combinations in the following sequences:

For increased rate and pitch, use first Higher followed by Faster.

For decreased rate and pitch, use first Slower followed by Lower.

Voice...

The slider in the dialog box indicates the current wave chunk size used to modify the sound wave    in the 
Faster, Slower, Higher and Lower commands.    The value denoted by "Decimate the File at 1/125 of a 
second" is the actual size of the wave chunk. This value may be set within a range between 1/50th of a 
second and 1/200th    of a second.    These limits have been set experimentally to work best in the 
modification of sound waves of human voices.    It is not necessary to know how these values change the 
wave effects.    It is sufficient to know that different wave chunk sizes work better for different voices (of 
different frequencies). The optimal value (or chunk size) for a particular voice must be found through 
experimentation.

Echo

The Echo command adds an echo to the sound wave.    Note that the sound wave duration is extended by
two seconds to provide room for the trailing echoes. Multiple invocations of the Echo command causes 
the initial wave loudness to increase since the echoes always fall on a consistent wave alignment.

Reverb

The Reverb command applies a reverberation to the sound wave.    The wave duration is extended    by 
two seconds to provide room for the trailing reverberation. This is an attempt to simulate the sound as if it 
were emitted    in a room with successive echoes bouncing off of three walls at three different distances 
from the source of the sound.    As in the echo effect, multiple invocations of the Reverb command 
increase the initial loudness of the sound file.    In this case, however, the results become more and more 
interesting, albeit less and less audible.

Reverse

The Reverse command simply reverses the sound wave.    The wave is then played starting at its end, 
and concluding at what was originally its beginning.    Two successive invocations of the Reverse 
command returns the sound wave to precisely its original state. It seems Reverse is the only truly 
reversible command.

Convert to 8-bit

This command allows you to convert ( i.e., downsample)    a 16-bit file into an 8-bit file.    Some versions of
16-bit capable hardware allow you to record in an 8-bit format, but also record a large amount of noise as 
well.    The solution to this problem is to record your waveform file in a 16-bit format and then use the 
Convert to 8-bit command to convert the waveform file. You can also use this command to reduce the size
( by one-half) of any 16-bit waveform file which you feel doesn't justify the extra disk space needed to 
store the file. 



Selecting A Region of a Wavefile
To edit a portion of a wavefile you must select a portion of the wavefile from within the view area. You can 
do this in one of two methods.    (1) Click on the mouse button while the insertion point is in the waveform 
view area and drag the mouse until a portion of the waveform is highlighted.    Dragging means pressing 
and holding down the mouse button and moving the mouse to a new position in the view area and then 
releasing the mouse button.(2) The second method involves a shifting and clicking motion.    Hold down 
the SHIFT key and then click the mouse button at a point in the view area. This method selects a region 
between the current insertion point (if no position has been selected the selection begins at the beginning 
of the view area) and the position where the mouse is clicked. 

In addition to the    two methods described above, you can zoom-in on a portion of the waveform file by 
placing the mouse within the view area and double-clicking.    Once you have this zoom view, it is possible
to select a portion of the wavefile larger than can be normally displayed in the view area.    Perform the 
following steps:

1.    Place the current position cursor ( the red line    in the waveform view area) to the beginning of the 
region you wish to select.    Next, scroll the view area to the part of the waveform region where you want 
the region to stop.

2.    Press the SHIFT key and simultaneously click on the mouse button.    The region between the two 
selection points becomes highlighted.

NOTE:    If a region is currently selected before performing the above steps, that region will be un-
selected. You cannot select a region    in the zoomed-in mode, then zoom-out while maintaining    that 
selection; consequently,    in order to zoom-out you must double-click on the waveform view window, 
which removes any defined selection.



To Play a Waveform File
1. Select "Open" from the File menu. 

2. Once the Open Wave File dialog box appears click on the disk drive or subdirectory where you have 
stored your waveform (*.WAV) files.

3. Highlight the waveform file you want to open. Click on the OK button.    The waveform file is 
automatically loaded into Pocket Recorder's view area. 

4. Click on the Play button  to playback the waveform file (or, if using the keyboard, tab to the Play 
button and hit the spacebar).    As it is played back, notice the activity of the VU meter. Both bars moving 
confirms that you have selected a waveform that was recorded in stereo. The green bar represents 
channel 1 and the blue bar represents channel 2.



To Record a Waveform File
Several options are available when recording waveform files. However, if a selection appears grayed-out, 
it simply means that it is not available with your version.    Before proceeding with these steps, ensure that
your microphone or audio device is plugged into either the microphone or line-in input plug on your sound 
card.

1. Select "New" from the File menu. Then click on the Record button .    The Record Data dialog box 
will appear: It has the following controls:

Sample Rate: Select either 44.1 kHz, 32.0 kHz, 22.05 kHz, 11.025 kHz, 8.0 kHz or a custom rate..    Keep
in mind that the larger the sampling rate, the more disk space is required to store the waveform file. 

Channels: Stereo.    If you are going to record in stereo, click on this button. Otherwise select Mono.

Sample: Select the 8-bit or 16-bit mode.    Pocket Recorder does not convert waveform files from different
formats.

Record Source: You can choose the source from which you want to record or use Pocket Mixer to select 
the source. You adjust the recording volume by using the slider in this box or using the Pocket Mixer 
sliders.

Peak Meter: The Peak meter shows you the recording level if the audio source from which you are going 
to record is currently in use (for example, a CD). Adjust the recording level by moving the slider with the 
mouse. You will see the changes in the recording level reflected in the Peak meter. To obtain the highest 
fidelity recording the recording level should be adjusted so that the meter occasionally hits the red zone, 
but without remaining there for a sustained period of time.

2.    When you are satisfied with the settings select Start Recording. 

3. Choose Stop Recording to stop recording.

4. If you want to hear your recording select Play Recording to playback the recording you just made. If 
you are satisfied with the recording choose Insert Recording. This will close the dialog box and insert a 
graphical representation of the recording in Pocket Recorder window.

NOTE: Pocket Recorder will not allow you to produce a recording larger in size than    the temporary 
recording file. Pocket Recorder always creates a temporary recording for use with the revert command.    
It is this temporary file that is recalled when you select    "Revert" from under the File menu. 

5. If you want to save the recording selecting Save As . . . from the File menu.

NOTE: Pocket Recorder uses an Auto-Stop feature when your temporary recording file becomes to large 
to be saved.    A message box appears indicating that the recording will be stopped. At this point, it is a 
good idea to save the file if any editing is to be performed which may increase the file's size.



Using OLE and Pocket Recorder
Object linking and embedding (OLE) is a Windows 3.1 system that enables applications to transfer data 
and to share data by establishing a common link between them.    In OLE the requesting application is 
called a client, while the application that provides data is called the server. Among the applications 
included with Windows 3.1, Paintbrush, Excel and Sound Recorder are OLE servers while Cardfile and 
Write are considered OLE clients. Pocket Recorder is an OLE server.    

The most common use of OLE is inserting voice annotations into your favorite word processor. The 
following example shows how to place a voice annotation within a Microsoft Word document.    Refer to 
your Windows 3.1 application documentation for specific requirements on using OLE.    The instructions 
below assume that you have a microphone    plugged into the external microphone jack of your sound 
card.

1. From within Microsoft Word select the Insert menu and choose Object....

2. Select "Pocket Recorder Wave" from within the Object dialog box and click on the OK button.

3. Once Pocket Recorder appears, click on the record button and record your voice annotation.    Click on 
the stop button to halt the recording (alternatively, you can select Pocket Recorder's File menu and open 
a pre-recorded WAV file).    

4. From within the File menu choose the "Return to Microsoft Word" selection (or double click on the 
control box - the little square with a horizontal bar at the upper left hand corner of Pocket Recorder).

5. Next,    a message box appears asking "Do You Want to Update the Changes in Microsoft Word?".    
Select "Yes" to continue. Once the Pocket Recorder icon appears in your document, all you have to do is 
double-click on it and Pocket Recorder will automatically play the voice annotation or WAV file.



Using Drag and Drop
Pocket Recorder supports drag and drop of waveform files. To use this feature start Pocket Recorder and 
place it in a minimized state on the Windows desktop. Then, select one or more waveform files, e.g., 
using the Windows File Manager, and drag and drop the selected group to Pocket Recorder and release. 
Pocket Recorder will now play each file. If Pocket Recorder is in a maximized state the file will be opened 
but will not be automatically played.



Pocket Recorder Controls and Status Fields

    Play - Press to start playback of wavefile.

    Move to start of wavefile.

    Advance to end of file.

    Stop.

    Record - brings up the record data dialog box..

 Erase - clears window of current file (same as choosing File New)

    Status Bar - describes the current status, i.e., recording , playing , stopped, etc.

    Amount of hard disk storage remaining on the volume where Pocket Recorder's temp 
directory is located.

    Displays the sampling frequency of the data in khz, and the sample size size as a 
superscript. Also displays either one speaker (mono) or two speakers (stereo) and the compression 
status.

    VU Meter - Displays the amplitude of the waveform (both left and right channels if the 
waveform data is stereo) during playback.



Using Compression/Decompression

In order to conserve disk space you can save your recorded files in compressed format. To do so select 
Save As in the File menu and choose one of the compression options.

Note that you can only select compression options for recordings sampled at 16 bits. These buttons are 
disabled (grayed out) if the file was recorded at 8 bits or if you have a 8-bit sound card. Compressed files 
are automatically decompressed when opened. Keep in mind that the audio quality will deteriorate over 
time as a file is compressed and decompressed. Also note the compression indicator on the main window
to the right of the stereo/mono indicators:

When opening a file the compression format of the file will be shown by this indicator. In the example 
above no compression is used.




